xampp 1.8.0 升级后修复 phpmyadmin

几天前出来 xampp 1.8.0 后从版本升级 1.7.7 我有一个很有趣的问题. Phpmyadmin-不是我的开放和与 izg″rmâvaše 403

禁止访问!


新 XAMPP 安全概念:

对所请求的对象的访问是仅可从本地网络.

此设置可以配置文件中 “httpd xampp.conf”.

现在开了 httpd conf xampp 到我......位于 / 选择/lampp/等/额外 /, 乍一看,一切都很好. 在本地网络规则都很好. 除此之外,我会打开本地主机. 跆拳道 ??? 我看了看日志,看看我的访问由 konfiguaciâta 切断. 这里的事情已经 ahnaha 我和坦率地一点点的运气的发现了一个问题. 之后再来一遍的 httpd。 conf 和锯在允许/拒绝条款最后一行 要求所有授予. 哦对尤里卡. 这是一个新的控制机制,进入 apache 2.4.x. 它给访问或拒绝这样一切都好, 基本上模仿允许/拒绝功能 :). 要解决这个问题,我们将添加要求所有被认为是理所当然的 / 选择/lampp/phpmyadmin 文件夹. 在我更改后看起来像这样

<目录 “/选择/lampp/phpmyadmin”>
AllowOverride AuthConfig 极限
命令允许,否认
允许来自所有
要求所有授予
</目录>

 

你始终可以尝试另一个 divoti, 例如,若要重命名文件夹 phpmyadmin 某事其他和别名做不到. 但它是丑陋和意义不大的 🙂

p.s 问我为什么我使用 XAMPP 不干净安装所有组件,因为它是我的 Debian 出生 – 答案是真的很简单 – 懒惰. 我太懒了,然后写多个命令得到 konfovete 等。. 很容易是以你整包 razarhiviraš 和光 😉

通过增强Zemanta

发表评论

您的电子邮件地址不会被公开. 必需的地方已做标记 *

反垃圾邮件 *