XAMPP 1.8.0 fixa phpmyadmin efter uppgradering

För några dagar sedan kom ut XAMPP 1.8.0 Efter uppgradering från version 1.7.7 Jag hade ett ganska intressant problem. PhpMyAdmin-inte min öppning och izg″rmâvaše med 403

Tillträde förbjudet!


Nytt XAMPP security koncept:

Tillgång till det begärda objektet är endast tillgänglig från det lokala nätverket.

Den här inställningen kan konfigureras i filen “httpd-xampp.conf”.

Nu öppnade jag den httpd-conf xampp vilket för mig... ligger i the/opt/lampp/etc/extra /, vid första anblicken, verkade allt bra. Reglerna för det lokala nätverket var fina. Bortsett från att jag skulle öppna localhost. WTF ??? Jag tittade på loggen och se att min tillgång är avskuren av konfiguaciâta. Här saker redan ahnaha mig och ärligt slags lite tur jag hittade problem. След като преглеждах httpd.conf-а видях в Tillåt/neka клаузите един последен ред Kräver alla beviljade. Åh till Eureka. Detta är den nya kontrollmekanism som trädde i Apache 2.4.x. Det ger tillgång till eller vägra sådan alla fina, i princip imiterade Allow/Deny funktionalitet :). За да поправим проблема добавяме kräver alla beviljade в директивите за папката /opt/lampp/phpmyadmin. Efter ändringarna i mig ser ut så här

<Katalog “/välja/lampp/phpmyadmin”>
AllowOverride AuthConfig gräns
Beställning tillåta,neka
Tillåta från alla
Kräver alla beviljade
</Katalog>

 

Du kan alltid prova en annan divoti, till exempel för att byta namn på mappen phpmyadmin något annat och inte alias till. Men det är fult och inte mycket meningsfull 🙂

p. s frågade mig varför jag använder XAMPP och inte ren installation av alla komponenter som det är min Debian föddes – svaret är väldigt enkelt – LÄTTJA. Mig för lat för att skriva flera kommandon då få konfovete etc.. Ganska lätt är ta din hela flocken razarhiviraš och ljus 😉

Förstärkt av Zemanta

Lämna svar

Din e-postadress kommer inte att publiceras. Obligatoriska fält är markerade *

Anti SPAM *