XAMPP 1.8.0 fix phpmyadmin după upgrade

Câteva zile afară XAMPP 1.8.0 ieri după upgrade de la versiunea 1.7.7 Am avut destul de o problemă interesantă. PhpMyAdmin și el nu se deschide și a urlat cu 403

Accesul interzis!


Noul concept de securitate XAMPP:

Accesul la obiectul solicitat este disponibil numai din rețeaua locală.

Această setare poate fi configurată în fișierul “httpd-xampp.conf”.

deschis imediat httpd-xampp.conf care pentru mine este în / opt / lampp / etc / extra /, La prima vedere, totul arata fin. Regulile pentru rețeaua locală au fost printre. În afară de localhost de deschidere. WTF ??? M-am uitat la log-și poate vedea că accesul meu este tăiat de konfiguatsiyata. Iată acum ce am suspinat și, sincer, oarecum mai puțin noroc găsit problema. După merge peste httpd. conf şi văzut în permite/Deny clauzele un ultimul rând Solicite toate acordate. Oh eureka. Acesta este un nou mecanism de control care a intrat în Apache 2.4.x. Acesta oferă acces sau refuzul unei astfel de amenzi, practic imita Allow / Deny funcționalitate :). Pentru a remedia problema adăugăm necesită toate acordate în folderul / opt/de lampp/phpmyadmin. După schimbările din mine arata ca

<director “/opt / lampp / phpMyAdmin”>
AllowOverride authconfig Limita
comanda permite,nega
Se lasă la toate
Solicite toate acordate
</director>

 

Viangi poate încerca un alt sălbatic, de exemplu, pentru a redenumi ceva dosar phpMyAdmin altul și nu alias pentru. Dar e urât și nu foarte semnificativ 🙂

P.S m-au întrebat de ce folosesc XAMPP nu instalare curată a tuturor componentelor așa cum le este Debian meu născut – Răspunsul este într-adevăr foarte simplu – LENE. Mi prea leneş pentru a scrie mai multe comenzi, apoi obţine konfovete etc.. Destul de uşor este să ia întregul pachet razarhiviraš şi de lumina 😉

Consolidată prin Zemanta

lasa un raspuns

Adresa ta de email nu va fi publicat. Câmpurile necesare sunt marcate *

Anti SPAM *