poporul meu Debian sunt din nou pătat pantaloni dependență. Adică nu murdar, dar acestea sunt lovind pachet IA32-libs, care este dependentă de skype. Nu voi comenta de ce dependenta lor este cu condiția ca este versiunea x64 😉 Deci, în cele din urmă, există mai multe aplicații care freca direct pentru eliminarea acestui pachet. Pentru bune sau rele nu se poate descurca fără ele, astfel, că este necesar să se recupereze pachetul. Cele mai simplă opțiune este de a adăuga testarea depozit și prioritizarea l, practic, este în destul de atât din nou în acest 😀 Pașii examinează în jos atunci când sistemul deja am actualizat și IA32-libs plecat.

1. Adauga o testare depozit sau wheezing- acesta este numele de cod al următorului Debian stabil. În /etc/apt/source.list adăuga o linie care arată în mod similar

deb http://debian.ludost.net/debian/ wheezy main contrib non-free

2. Acordăm prioritate pachetelor de testare mai mari decât cele de depozite instabile ca în momentul în care pachetul încă acolo. Creați /etc/apt/preferences.d/apt fișier (aceasta este alegerea mea personală) poate fi în / etc / apt / preferințele în loc să /etc/apt/preferences.d/ și sa adăugați următorul conținut

Package: *
Pin: release a=testing
Pin-Priority: 1010

3. actualizare apt-get pentru a actualiza noile priorități și registrele centrale. Se trage de pe noul lor skype, care este în prezent la versiunea 4.0.0.8.1 și să-l dpkg instalați și apoi reparați pachetele lipsă

dpkg -i skype-debian_4.0.0.8-1_amd64.deb

apt-get install -f

 

В доста общи линии това е процедура за принудително сваляне на версиите на пакетите но аз съм я използвал само за тези за които ми трябва в последствие може дадете приоритет на ia32-libs ia32-libs-gtk lib32v4l-0 să fie eliminate prin alimentator de testare.