XAMPP 1.8.0 ਠੀਕ phpmyadmin ਦੇ ਬਾਅਦ ਅੱਪਗਰੇਡ

ਕੁਝ ਦਿਨ ਬਾਹਰ XAMPP 1.8.0 ਕੱਲ੍ਹ ਨੂੰ ਵਰਜਨ ਤੱਕ ਅੱਪਗਰੇਡ ਦੇ ਬਾਅਦ 1.7.7 ਮੈਨੂੰ ਕਾਫ਼ੀ ਇੱਕ ਦਿਲਚਸਪ ਸਮੱਸਿਆ ਸੀ. Phpmyadmin-ਅਤੇ ਉਸ ਨੇ ਖੋਲ ਨਹੀ ਕਰਦਾ ਹੈ ਅਤੇ ਨਾਲ ਗੱਜਿਆ 403

ਪਹੁੰਚ ਮਨ੍ਹਾ!


ਨ੍ਯੂ XAMPP ਸੁਰੱਖਿਆ ਨੂੰ ਸੰਕਲਪ:

ਬੇਨਤੀ ਕੀਤੀ ਇਕਾਈ ਦਾ ਪਹੁੰਚ ਲੋਕਲ ਨੈੱਟਵਰਕ ਤੱਕ ਹੀ ਉਪਲਬਧ ਹੈ.

ਇਹ ਸੈਟਿੰਗ ਫਾਇਲ ਵਿੱਚ ਸੰਰਚਿਤ ਕੀਤਾ ਜਾ ਸਕਦਾ ਹੈ “httpd-xampp.conf”.

ਤੁਰੰਤ httpd-xampp.conf, ਜੋ ਕਿ ਮੇਰੇ ਲਈ / opt / lamp ਵਿੱਚ ਹੈ ਖੋਲ੍ਹਿਆ / etc / ਵਾਧੂ /, ਪਹਿਲੀ ਨਜ਼ਰ 'ਤੇ ਸਭ ਕੁਝ ਜੁਰਮਾਨਾ ਦੇਖਿਆ. ਲੋਕਲ ਨੈੱਟਵਰਕ ਲਈ ਨਿਯਮ ਸਨ. ਇਲਾਵਾ ਉਦਘਾਟਨੀ ਲੋਕਲਹੋਸਟ ਤੱਕ. WTF ??? ਮੈਨੂੰ 'ਤੇ ਦੇਖਿਆ ਲਾਗ-ਅਤੇ ਦੇਖੋ ਕਿ ਮੇਰੇ ਪਹੁੰਚ konfiguatsiyata ਕੇ ਕੱਟ ਰਿਹਾ ਹੈ,. ਇੱਥੇ ਹੁਣ ਮੈਨੂੰ ਕੀ gasped ਅਤੇ ਸਾਫ਼ ਕੁੱਝ ਘੱਟ ਕਿਸਮਤ ਸਮੱਸਿਆ ਦਾ ਪਤਾ ਲੱਗਿਆ ਹੈ. След като преглеждах httpd.conf-а видях в Allow/Deny клаузите един последен ред ਸਾਰੇ ਦਿੱਤੀ ਲੋੜ. ਓ ਯਰੀਕਾ. ਇਹ ਹੈ ਜੋ ਵਿੱਚ ਗਿਆ, ਇੱਕ ਨਵ ਕੰਟਰੋਲ ਵਿਧੀ ਹੈ ਅਪਾਚੇ 2.4.x. ਇਹ ਪਹੁੰਚ ਜ ਅਜਿਹੇ ਕਿਸੇ ਵੀ ਜੁਰਮਾਨਾ ਇਨਕਾਰ ਕਰਦਾ ਹੈ, ਅਸਲ mimics ਇਜਾਜ਼ਤ / ਕਾਰਜਕੁਸ਼ਲਤਾ ਪਾਬੰਦੀ :). За да поправим проблема добавяме Require all granted в директивите за папката /opt/lampp/phpmyadmin. ਤਬਦੀਲੀ ਮੇਰੇ ਵਿੱਚ ਦਿਸਦਾ ਹੈ ਦੇ ਬਾਅਦ

<ਡਾਇਰੈਕਟਰੀ “/opt / lamp / phpmyadmin”>
AllowOverride authconfig ਸੀਮਾ
ਆਰਡਰ ਦੀ ਇਜਾਜ਼ਤ,ਇਨਕਾਰ
ਸਾਰੇ ਦੀ ਇਜ਼ਾਜਤ
ਸਾਰੇ ਦਿੱਤੀ ਲੋੜ
</ਡਾਇਰੈਕਟਰੀ>

 

Viangi ਇਕ ਹੋਰ ਜੰਗਲੀ ਕੋਸ਼ਿਸ਼ ਕਰ ਸਕਦੇ ਹੋ, ਉਦਾਹਰਨ ਲਈ, ਫੋਲਡਰ phpmyadmin ਹੋਰ ਕਿਸੇ ਚੀਜ਼ ਨੂੰ ਬਦਲੋ ਅਤੇ ਕਰਨ ਲਈ ਉਰਫ ਨਾ ਨੂੰ ਕੀ ਕਰਨ ਦੀ. ਪਰ ਇਸ ਨੂੰ ਬਦਸੂਰਤ ਹੈ ਅਤੇ ਬਹੁਤ ਹੀ ਅਰਥਪੂਰਨ ਨਹੀ ਹੈ 🙂

p.s ਉਹ ਮੈਨੂੰ ਇਸੇ ਕਰਕੇ ਮੈਨੂੰ XAMPP ਸਭ ਭਾਗ ਦੇ ਨਾ ਸਾਫ਼ ਇੰਸਟਾਲੇਸ਼ਨ ਲਈ ਵਰਤਣ ਨੂੰ ਕਿਹਾ ਹੈ ਦੇ ਤੌਰ ਤੇ ਉਹ ਮੇਰੇ ਡੇਬੀਅਨ ਦਾ ਜਨਮ ਹੁੰਦਾ ਹੈ – отговорът е много много простМЪРЗЕЛ. Мързи ме да напиша няколко команди после да си пипна конфовете и прочие. Доста по лесно е сваляш целия пакет разархивираш и палиш 😉

Zemanta ਨਾਲ ਲੈੱਸ

ਕੋਈ ਜਵਾਬ ਛੱਡਣਾ

ਤੁਹਾਡਾ ਈਮੇਲ ਪਤਾ ਪ੍ਰਕਾਸ਼ਿਤ ਨਹੀ ਕੀਤਾ ਜਾ ਜਾਵੇਗਾ. ਦੀ ਲੋੜ ਹੈ ਖੇਤਰ ਮਾਰਕ ਕੀਤੇ ਹਨ, *

ਵਿਰੋਧੀ ਸਪਮ *