XAMPP 1.8.0 fix phpmyadmin na de upgrade

Een paar dagen uit XAMPP 1.8.0 gisteren na upgrade van versie 1.7.7 Ik had nogal een interessant probleem. Phpmyadmin-en hij gaat niet open en brulde met 403

Toegang verboden!


Nieuwe XAMPP beveiligingsconcept:

De toegang tot het gevraagde object is alleen beschikbaar vanaf het lokale netwerk.

Deze instelling kan worden geconfigureerd in het bestand “httpd-xampp.conf”.

Meteen opende httpd-xampp.conf die mij in de map / opt / lampp / etc / extra /, Op het eerste gezicht leek alles goed. De regels voor het lokale netwerk behoorden. Afgezien van de opening localhost. WTF ??? Ik keek naar de log-en zie dat mijn toegang wordt afgesneden door konfiguatsiyata. Hier nu wat ik hapte naar adem en eerlijk gezegd wat minder geluk vond het probleem. Na het doorlopen van httpd.conf-en zag in Toestaan ​​/ Weigeren clausules één laatste bestelling Vereisen dat alle verleende. Oh eureka. Dit is een nieuwe controle-mechanisme dat aangegane Apache 2.4.x. Het geeft toegang tot of een dergelijke boete weigeren, in principe bootst Toestaan ​​/ Weigeren functionaliteit :). Om het probleem op te lossen toe te voegen vereisen alle verleende richtlijnen voor de map / opt / lampp / phpmyadmin. Na de veranderingen in mij eruit ziet

<directory “/opt / lampp / phpmyadmin”>
AllowOverride AuthConfig Limit
Bestel toestaan,ontkennen
Toestaan ​​van alle
Vereisen dat alle verleende
</directory>

 

Viangi kan een ander wilde proberen, bijvoorbeeld naar de map phpmyadmin iets andere naam geven en niet alias. Maar het is lelijk en niet erg zinvol 🙂

P.S Ze vroegen me waarom ik XAMPP geen schone installatie van alle componenten te gebruiken als ze is mijn Debian geboren – Het antwoord is heel simpel – luiheid. Lazy me om een ​​paar commando's te schrijven toen raakte zijn konfovete etc.. Veel gemakkelijker is het raken van het hele pakket en pak je licht 😉

Versterkt door Zemanta

Laat een antwoord achter

Uw e-mailadres zal niet worden gepubliceerd. Verplichte velden zijn gemarkeerd *

Anti SPAM *