Ծրագրի xampp 1.8.0 ուղղումներ phpmyadmin հետո թարմացումները

Մի քանի օր առաջ դուրս է եկել Ծրագրի xampp 1.8.0 երեկ թարմացման տարբերակ 1.7.7 ինձ շատ հետաքրքիր խնդիր է. Phpmyadmin-չի բացվել, և ես покатился հետ 403

Access forbidden!


New XAMPP security առաջընթացը:

Access to the requested օբյեկտի is only available from the local network.

This setting can be configured in the file “httpd-xampp.հակամարտութ”.

Անմիջապես ես բացեցի httpd-xampp.conf ով ինձ մոտ է գտնվում /opt/lampp/etc/extra/, առաջին հայացքից ամեն ինչ նորմալ է. Կանոնները համար լոկալ ցանցում կարգով. Հետ մեկտեղ բացման տեղական. WTF ??? Նայեցի log-իսկ ես նայում, որ իմ մուտք է եղել отрезан է конфигуацията. Ահա հիմա բոլորը ինձ ахнаха եւ, անկեղծ ասած, մի փոքր հաջողություն, ես գտա խնդիրը. След като преглеждах httpd.conf-а видях в Allow/Deny клаузите един последен ред Require all granted. Մասին էվրիկա!. Սա նոր վերահսկողության մեխանիզմը, որը ներառում է apache 2.4.x. Հետ չեն տալիս մուտք գործել կամ հրաժարում նման անհրաժեշտ, հիմնականում նմանակող Լուծել/Արգելել ֆունկցիոնալ :). За да поправим проблема добавяме Require all granted в директивите за папката /opt/lampp/phpmyadmin. Հետո փոփոխություններ են ինձ նայում, այնքան

<Կատալոգ “/opt/lampp/phpmyadmin”>
AllowOverride AuthConfig Սահմանափակել
Order allow,արգելել
Allow from all
Require all granted
</Կատալոգ>

 

Թեեւ դա ճիշտ է, կարող եք փորձել և այլ վայրի, օրինակ, որպեսզի վերանվանել թղթապանակը phpmyadmin ինչ-որ բան այլ է, եւ անել alias ոչ. Բայց դա տգեղ է եւ հատկապես կարեւոր է 🙂

p.s Հարցնում էին ինձ, թե ինչու եմ օգտագործում են XAMPP, այլ ոչ թե մաքուր տեղադրել բոլոր բաղադրիչների, իսկ նրանց իմ Debian ծնվել – отговорът е много много простМЪРЗЕЛ. Мързи ме да напиша няколко команди после да си пипна конфовете и прочие. Доста по лесно е сваляш целия пакет разархивираш и палиш 😉

Ընդլայնված by Zemanta

Leave a Reply

Ձեր email address will not be published. Պարտադիր դաշտերը նշված են *

Հակա-սպամ *