Debian-kansaani ovat edelleen likaisia ​​riippuvuuksien kanssa. Т.е не са ги оцапали ами са разкарали пакета ia32-libs който е в зависимостите на skype. En kommentoi miksi ne ovat riippuvuussuhteissa, koska se on x64-versio 😉 Joten lopulta useita sovelluksia poistetaan suoraan paketin poistamisen vuoksi. Paremmin tai huonommin, en voi tehdä ilman heitä, että paketti on palautettava. Helpoin vaihtoehto on lisätä testausvarasto ja antaa etusijalle se yleensä, koska tämä on aivan yhtä paljon 😀 Seuraavissa vaiheissa tarkastellaan järjestelmää, kun olemme jo päivittäneet sen, ja ia32-libs ei ole enää.

1. Добавяме testing хранилище или wheezy- това е кодовото име на следващия stable Debian. В /etc/apt/source.list добавете ред който изглежда по подобен начин

deb http://debian.ludost.net/debian/ wheezy main contrib non-free

2. Даваме приоритет на testing пакетите над тези на unstable хранилищата тъй като към момента пакета все още го има там. Създаваме файлът /etc/apt/preferences.d/apt (това си е лично мой избор) може да е в /etc/apt/preferences вместо /etc/apt/preferences.d/ и му добавяме следното съдържание

Package: *
Pin: release a=testing
Pin-Priority: 1010

3. apt-get update за да обнови новите хранилища и приоритети. Lataat uuden skypesi, joka on tällä hetkellä versio 4.0.0.8.1 ja asenna se dpkg ja korjaa puuttuvat paketit

dpkg -i skype-debian_4.0.0.8-1_amd64.deb

apt-get install -f

 

В доста общи линии това е процедура за принудително сваляне на версиите на пакетите но аз съм я използвал само за тези за които ми трябва в последствие може дадете приоритет на ia32-libs ia32-libs-gtk lib32v4l-0 ladataan vain testisyöttölaitteesta.