Packet Tracer

Image via Wikipedia

Hoy tuve que demostrar una simulación Packet Tracer de Cisco a través de una máquina en la que no se instaló. En General, es maloumŝinata, que es el simulador de Cisco para x86 máquinas y para mi fue la máquina x64. Cuando intenta instalar muere con el mensaje feo

Intentar instalar el paquete ahora
dpkg: Error al procesar PacketTracer-5.3_3.i386.deb (–instalar):
arquitectura del paquete (i386) no coincide con el sistema (AMD64)
Se encontraron errores al procesar:
PacketTracer-5.3_3.i386.deb

Casi todo es obviamente Debian apli paquete quiere instalar porque es para una arquitectura diferente. De aquí en fuera es un claro problema dpkg + forsirano instalar el error que podemos bypass para una plataforma diferente. Bin-pean instalador archivo tiene razarhiviraŝ es el archivo descomprime en/tmp/selfextract. Carpeta donde XXXXX XXXXX es cualquier cadena de caracteres. En este directorio se encuentran. archivo deb Packet Tracer-a. La instalación se realiza con el comando

dpkg -i --force-all /tmp/selfextract.XXXXX/PacketTracer-5.3_3.i386.deb

Naturalmente con derechos de root.

Mejorado por Zemanta