Packet Tracer

Image via Wikipedia

Today I had to demonstrate a simulation Cisco Packet Tracer through a machine on which was not installed. In General, maloumŝinata is, that the simulator of Cisco is for x86 machines and to me the machine was x64. When you try to install dies with the ugly message

Attempting to install package now
dpkg: error processing PacketTracer-5.3_3.i386.deb (–install):
package architecture (i386) does not match system (amd64)
Errors were encountered while processing:
PacketTracer-5.3_3.i386.deb

Pretty much everything is obviously Debian-pean package wants to install because it is for a different architecture. From here on out is a clear problem dpkg + forsirano to install the error we can bypass for a different platform. Bin-pean Installer file has only razarhiviraŝ is that archive unpacks into/tmp/selfextract. Folder where XXXXX XXXXX is any string. In this directory are located. deb file Packet Tracer-a. The installation is done with the command

dpkg -i --force-all /tmp/selfextract.XXXXX/PacketTracer-5.3_3.i386.deb

Naturally with root rights.

Enhanced by Zemanta