XAMPP 1.8.0 επιδιόρθωση phpmyadmin μετά την αναβάθμιση

Πριν από λίγες μέρες βγήκε XAMPP 1.8.0 Μετά την αναβάθμιση από την έκδοση 1.7.7 Είχα ένα αρκετά ενδιαφέρον πρόβλημα. PhpMyAdmin-όχι άνοιγμα μου και izg″rmâvaše με 403

Δεν επιτρέπεται η πρόσβαση!


Νέα XAMPP ασφαλείας έννοια:

Πρόσβαση στο ζητούμενο αντικείμενο είναι διαθέσιμο μόνο από το τοπικό δίκτυο.

Αυτή η ρύθμιση μπορεί να ρυθμιστεί στο αρχείο “httpd-xampp.conf”.

Τώρα άνοιξα το xampp httpd-conf που για μένα... βρίσκεται στο το/opt/lampp/κλπ/έξτρα /, με την πρώτη ματιά, όλα φαίνονταν εντάξει. Οι κανόνες για το τοπικό δίκτυο ήταν μια χαρά. Εκτός από το ότι θα ανοίξει το localhost. ΤΙ ΣΤΟ ΔΙΆΛΟ ??? Κοίταξα το αρχείο καταγραφής και να δείτε ότι έχει αποκοπεί η πρόσβαση μου από konfiguaciâta. Εδώ πράγματα ήδη ahnaha μου και ειλικρινά είδος λίγη τύχη βρήκα το πρόβλημα. След като преглеждах httpd.conf-а видях в Allow/Deny клаузите един последен ред Απαίτηση όλων χορηγείται. Ω στο Εύρηκα. Αυτό είναι το νέο μηχανισμό ελέγχου που τέθηκε σε Apache 2.4.x. Δίνει πρόσβαση ή την άρνηση αυτή όλα μια χαρά, βασικά μιμούνταν Allow/Deny λειτουργία :). За да поправим проблема добавяме Require all granted в директивите за папката /opt/lampp/phpmyadmin. Μετά τις αλλαγές μου μοιάζει με αυτό

<Κατάλογος “/opt/lampp/phpmyadmin”>
AllowOverride AuthConfig όριο
Επιτρέψει την παραγγελία,αρνηθεί
Επιτρέψτε από όλους
Απαίτηση όλων χορηγείται
</Κατάλογος>

 

Μπορείτε πάντα να δοκιμάσετε ένα άλλο divoti, για παράδειγμα, για να μετονομάσετε το φάκελο phpmyadmin κάτι άλλο και δεν ψευδώνυμο για να. Αλλά είναι άσχημο και δεν είναι πολύ σημαντική 🙂

π. σ ρώτησα εμένα γιατί χρησιμοποιούν XAMPP και όχι καθαρή εγκατάσταση όλων των συστατικών όπως είναι Debian μου γεννήθηκε – отговорът е много много простМЪРЗЕЛ. Мързи ме да напиша няколко команди после да си пипна конфовете и прочие. Доста по лесно е сваляш целия пакет разархивираш и палиш 😉

Ενισχυμένη από Zemanta

Αφήνω μια απάντηση

Your email address will not be published. Required fields are marked *

Anti SPAM *