skype in debian sid x64

Моите хора от Debian пак са оцапали гащите със зависимостите. Das heißt, sie haben sie nicht angefärbt, sondern das ia32-libs-Paket verloren, das sich in den Abhängigkeiten von Skype befindet. Ich werde nicht kommentieren, warum sie in Abhängigkeit sind, da es sich um eine x64-Version handelt. 😉 Am Ende gibt es also mehrere Anwendungen, die aufgrund des Entfernens dieses Pakets direkt gelöscht werden. Zum Guten oder Schlechten kann ich nicht ohne sie auskommen, dass das Paket wiederhergestellt werden muss. Най лесния вариант е да се добави testing хранилище и да се даде приоритет на него в общи линии е това в е чак толкова пак това 😀 Стъпките по надолу разглеждат системата когато вече сме я обновили и ia32-libs вече го няма.

1. Добавяме testing хранилище или wheezy- това е кодовото име на следващия stable Debian. В /etc/apt/source.list добавете ред който изглежда по подобен начин

deb http://debian.ludost.net/debian/ wheezy main contrib non-free

2. Даваме приоритет на testing пакетите над тези на unstable хранилищата тъй като към момента пакета все още го има там. Създаваме файлът /etc/apt/preferences.d/apt (това си е лично мой избор) може да е в /etc/apt/preferences вместо /etc/apt/preferences.d/ и му добавяме следното съдържание

Package: *
Pin: release a=testing
Pin-Priority: 1010

3. apt-get update за да обнови новите хранилища и приоритети. Смъквате си skype на ново които към момента е версия 4.0.0.8.1 и си го инсталирате dpkg и след това си поправяте липсващите пакети

dpkg -i skype-debian_4.0.0.8-1_amd64.deb

apt-get install -f

 

В доста общи линии това е процедура за принудително сваляне на версиите на пакетите но аз съм я използвал само за тези за които ми трябва в последствие може дадете приоритет на ia32-libs ia32-libs-gtk lib32v4l-0 darf nur vom Test-Feeder heruntergeladen werden.

Hinterlasse eine Antwort

Ihre E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *

Anti-SPAM *