XAMPP 1.8.0 Fix phpmyadmin efter opgradering

For et par dage siden kom ud XAMPP 1.8.0 i går efter opgradering fra version 1.7.7 Jeg har en temmelig interessant problem. Phpmyadmin åbnes ikke, og jeg rullede med 403

Adgang forbudt!


Nye XAMPP sikkerhedskoncept:

Adgang til det ønskede objekt er kun til rådighed fra det lokale netværk.

Denne indstilling kan være konfigureret i filen “httpd-xampp.Conf”.

Straks jeg åbnede httpd-xampp.conf som jeg har, er i /opt/lampp/etc/extra/, ved første øjekast ser alt fint. Regler for LAN var OK. Sammen med åbningen lokale. WTF ??? Så på den log, og jeg kan se, at min adgang er blevet afskåret fra konfiguratuta. Nu er alle jeg ahaha, og, helt ærligt, en smule held, jeg har fundet problemet. След като преглеждах httpd.conf-а видях в Allow/Deny клаузите един последен ред Kræver, at alle, der ydes. Om Eureka!. Dette er et nyt kontrol-mekanisme, som er inkluderet i apache 2.4.x. Med ham ikke giver adgang til eller frafaldelse af en sådan kræves, dybest set efterligne Aktivere/deaktivere funktionalitet :). За да поправим проблема добавяме Require all granted в директивите за папката /opt/lampp/phpmyadmin. Efter ændring af mit udseende, så

<Bibliotek “/opt/lampp/phpmyadmin”>
AllowOverride AuthConfig Grænse
For at tillade,forbud
Tillad fra alle
Kræver, at alle, der ydes
</Bibliotek>

 

Mens det er sandt, kan du prøve en anden vilde, for eksempel, for at omdøbe den phpmyadmin mappen til noget andet og ikke alias. Men det er grimt og ikke særlig betydelige 🙂

s.s Spurgte mig, hvorfor jeg bruger XAMPP i stedet for en ren installation af alle komponenterne, og det er, min Debian blev født – отговорът е много много простМЪРЗЕЛ. Мързи ме да напиша няколко команди после да си пипна конфовете и прочие. Доста по лесно е сваляш целия пакет разархивираш и палиш 😉

Forstærket af Zemanta

efterlade et svar

Din e-mail-adresse vil ikke blive offentliggjort. Krævede felter er markeret *

Anti-SPAM *