XAMPP 1.8.0 opravit phpMyAdmin po upgradu

Před pár dny vyšel XAMPP 1.8.0 Po inovaci z verze 1.7.7 Měl jsem docela zajímavý problém. PhpMyAdmin není můj úvodní a izg″rmâvaše s 403

Přístup zakázán!


Nová koncepce zabezpečení XAMPP:

Přístup k požadovanému objektu je pouze k dispozici v místní síti.

Toto nastavení lze konfigurovat v souboru “httpd-xampp.conf”.

Teď jsem otevřela httpd-conf xampp což je pro mě... se nachází v the/opt/lampp/etc/extra /, na první pohled všechno zdálo fine. Pravidla pro místní síť, byly v pořádku. Kromě toho by otevřete localhost. WTF ??? Jsem se podíval na protokolu a vidět, že můj přístup je úkonem konfiguaciâta. Musím říct už ahnaha a upřímně druh trochu štěstí jsem našel problém. Poté, co nad httpd. conf a pila v posledním řádku povolit/zakázat klauzule jeden Požadovat, aby všechny poskytnuté. Oh do Eureky. To je nový kontrolní mechanismus, který vstoupil do Apache 2.4.x. To dává přístup nebo odmítnutí takové vše v pořádku, v podstatě napodobil povolit/zakázat funkce :). K nápravě tohoto problému jsme přidali, vyžadují všechny udělené v the/opt/lampp/phpmyadmin složka. Po změnách ve mně vypadá takto

<Adresář “/opt/lampp/phpmyadmin”>
AllowOverride AuthConfig Limit
Objednávky umožňují,Odepřít
Povolení od všech
Požadovat, aby všechny poskytnuté
</Adresář>

 

Vždy můžete zkusit další divoti, Například přejmenovat složku phpmyadmin něco jiného a ne alias na. Ale je to ošklivý a velmi významné 🙂

p. s kladené, proč jsem použít XAMPP, a ne čisté instalaci všech součástí, jak je můj Debian se narodila – odpověď je opravdu velmi jednoduchá – LENOST. Já příliš líný psát více příkazů a pak se konfovete atd.. Poměrně snadné je vzít celý pack razarhiviraš a lehké 😉

Umocněn Zemanta

zanechte odpověď

Vaše e-mailová adresa nebude zveřejněna. Povinné položky jsou označeny *

Anti Spam *