/dev/random

Měl jsem docela zajímavý hlavolam hlavolam – Musel jsem vytvořit několik náhodně generovaných hesel, jako jsem měl požadavek mít pevnou délku obsahovat velká a malá písmena a číslice, normální věci. Zní to snadné právo a v podstatě je. Použil jsem /dev/urandom pro osnonvata generaci a pak s krátkou dopravní pás byl filtrování požadovaný počet znaků a typy znaků, které musí být použity. Tak dlouho, jak já jsem mazlavého mýdla v hlavním skriptu je dopravní pás :

cat /dev/urandom | tr -dc '[:alnum:]' | fold -w 20| head -n 1

Tak se pojďme podívat trochu podrobněji, co se tady děje. Vyjeďte výjezdem cat/dev/urandom. Pak filtr zobrazíte pouze malé, Velká písmena a čísla. Pak Přeložte omezení délky řetězce k číslu USA. Konečně, omezení zobrazovat pouze 1 celý řádek výstupu. V podstatě stejně snadné jako 1-2-3. Pokud chcete zvýšit složitost hesla a specialenite znaky v regulâârni výrazu tr lze použít :graf: nebo :vytisknout: Namísto :alnum:, které zahrnují všechny znaky s nebo bez mezery.

cat /dev/urandom | tr -dc '[:graph:]' | fold -w 20 | head -n 1
Umocněn Zemanta

Moji lidé z Debian má zásuvky se závislostmi. To není co mám je balík ia32-libs, která je v závislosti na skype. Já nebudu komentář o proč jejich rodinných příslušníků za předpokladu, že je to verze 😉 h64, takže nakonec existuje několik aplikací, které jsou odstraněny přímo kvůli odstranění tohoto balíčku. Pro dobré nebo špatné neexistuje žádný způsob, jak to provést bez nich, Je nutné obnovit balíčku. Nejjednodušší možností je přidání testování úložiště a dát přednost k němu obecně podmínky je, že v tak to 😀 kroky dále dolů v systému jsme při pohledu na při aktualizaci a ia32-libs už je pryč.

1. Přidat testování úložiště nebo sípání- To je kódové označení pro příští stabilní Debian. Přidat řádek in/etc/apt/source.list který vypadá podobně jako tento

deb http://debian.ludost.net/debian/ wheezy main contrib non-free

2. Dáváme přednost testování balíčků nad zájmy nestabilní repozitáře jako balíček v současné době ještě ji tam. Vytvořit file/etc/apt/preferences.d/apt (Je to moje volba) může být v/etc/apt/předvolby místo of/etc/apt/preferences.d/and přidejte následující obsah

Package: *
Pin: release a=testing
Pin-Priority: 1010

3. apt-get update pro aktualizaci nové úložiště a priority. Váš nový skype Sm″kvate, který je v současné době verze 4.0.0.8.1 a nainstalujte dpkg a pak opravit chybějící balíčky

dpkg -i skype-debian_4.0.0.8-1_amd64.deb

apt-get install -f

 

To je docela obecně postup Vynucené stahování verzí balíčků, ale použil jsem to jen pro ty, kteří ji potřebují může nakonec dát přednost ia32-libs-gtk ia32-libs lib32v4l-0 Chcete-li odstranit pouze testování ptačí krmítko.

English: This is a side view of the read head ...

Včera jsem musel vyzvednout VM Windowds SYSTÉM SOUBORŮ NTFS můj podíl. K mému velkému úžasu, stroj začal protahovat hodně po spuštění VirtualBoxu vytváří virtuální PEVNÝ DISK. WFT ??? Teď rychle a po ruce vrchol problém. NTFS - 3g orání na 100% využití procesoru 3 6 moje jádra. Hm divné. Po nohou rozjímání v tomto pořadí problému onanovat

/sbin/mount.ntfs-3g /dev/sda4 /media/disk1part4 -o rw

Zjevně/dev/sda4 je namontovat pouze s výchozími možnostmi. Ovladač systému souborů NTFS mají obecně nuttin starosti s intenzivní psaní a čtení v více akcií, které nejsou vykreslovány mu trochu zázračné nastavení.

  1. big_writes – Nejdůležitější volba klesat intenzita zátěže na vašem systému pomocí záznamu velkých bloků.
  2. noatime – urychluje systém tím, že zakazují obnovení inode čas přístupu Pokud není nutné. Osobně já nemám
  3. windows_names – Zde neexistuje žádné zrychlení, ale názvy souborů jsou zpracovány podle konvence, podle nichž souboru MS názvy bez ohledu na to, zda se jedná o velké a malé písmena jsou stejné ilki.

Po opravil jsem obě možnosti se připojit můj oddíl fstab záznam vypadal takto

UUID=2213f519-f980-42bf-9e25-9201db38c458  /media/disk1part4  ntfs-3g  defaults,big_writes,windows_names,noatime 0 0

Umocněn Zemanta

Nějakou dobu jsem si všiml, že přestal pracovat. GNOME shell počasí rozšíření-mě. V podstatě nebyl zakňučel aktuální verzi mou verzi GNOME Shell. Divné, protože když jsem aktualizoval aktualizovat verzi gnome shellu. Pak mu dala kopačky, protože to je bolest zemřít a ještě méně jich mít čas ponořit se do takové malé chyby. Ale dnes jsem si, že je čas to ukončit a získat čudesiâta. Aktualizoval jsem git stromu na nejnovější verzi, Nainstaloval jsem nový – beze změny. WTF. Pak jsem ho praštil make uninstall a objeví se něco šokujícího, doplněk byl stále deaktivován není aktualizován, a bylo to deinstaliral. V podstatě v tomto okamžiku napadlo, mám to nainstalované a v některých dalších rozšíření složky a tak tak kříž s. Od nynějška se věci vyvíjejí v následujících scénářích. Vyhledejte název doplňku, vyhledejte doplněk a odstranit. Užívání jména instaliranete aditiv v gnome shellu drží s následujícím příkazem

gsettings get org.gnome.shell enabled-extensions

Mimochodem z jsem si uvědomil, Jsem aktivován doplněk s názvem [email protected] Zábava. Příjemné je tomu v případě, že je název složky těchto přídavných látek a může být snadno opertes umístění a velení

find / -name '[email protected]'

Věci se stávají snadnou. Výsledek find-realizovaný, mít v 2 obruč. Rychlé rm -rf je 2 Papac a všechno do sebe zapadlo. Rychlá instalace add-on a restartovat GNOME Shell.

Umocněn Zemanta

Před pár dny vyšel XAMPP 1.8.0 Po inovaci z verze 1.7.7 Měl jsem docela zajímavý problém. PhpMyAdmin není můj úvodní a izg″rmâvaše s 403

Přístup zakázán!


Nová koncepce zabezpečení XAMPP:

Přístup k požadovanému objektu je pouze k dispozici v místní síti.

Toto nastavení lze konfigurovat v souboru “httpd-xampp.conf”.

Teď jsem otevřela httpd-conf xampp což je pro mě... se nachází v the/opt/lampp/etc/extra /, na první pohled všechno zdálo fine. Pravidla pro místní síť, byly v pořádku. Kromě toho by otevřete localhost. WTF ??? Jsem se podíval na protokolu a vidět, že můj přístup je úkonem konfiguaciâta. Musím říct už ahnaha a upřímně druh trochu štěstí jsem našel problém. Poté, co nad httpd. conf a pila v posledním řádku povolit/zakázat klauzule jeden Požadovat, aby všechny poskytnuté. Oh do Eureky. To je nový kontrolní mechanismus, který vstoupil do Apache 2.4.x. To dává přístup nebo odmítnutí takové vše v pořádku, v podstatě napodobil povolit/zakázat funkce :). K nápravě tohoto problému jsme přidali, vyžadují všechny udělené v the/opt/lampp/phpmyadmin složka. Po změnách ve mně vypadá takto

<Adresář “/opt/lampp/phpmyadmin”>
AllowOverride AuthConfig Limit
Objednávky umožňují,Odepřít
Povolení od všech
Požadovat, aby všechny poskytnuté
</Adresář>

 

Vždy můžete zkusit další divoti, Například přejmenovat složku phpmyadmin něco jiného a ne alias na. Ale je to ošklivý a velmi významné 🙂

p. s kladené, proč jsem použít XAMPP, a ne čisté instalaci všech součástí, jak je můj Debian se narodila – odpověď je opravdu velmi jednoduchá – LENOST. Já příliš líný psát více příkazů a pak se konfovete atd.. Poměrně snadné je vzít celý pack razarhiviraš a lehké 😉

Umocněn Zemanta