Праграме xampp 1.8.0 выпраўленні ў phpmyadmin пасля абнаўлення

Праз некалькі дзён з Праграме xampp 1.8.0 учора пасля абнаўлення з версіі 1.7.7 Я меў даволі цікавую праблему. PHPMYADMIN-і ён не адкрываецца, і зароў 403

доступ забаронены!


Новая канцэпцыя бяспекі XAMPP:

Доступ да запытаныя аб'екты даступная толькі з лакальнай сеткі.

Гэты параметр можна наладзіць ў файле “HTTPD-xampp.conf”.

Адразу адкрылі HTTPd-xampp.conf, які для мяне з'яўляецца ў / Opt / lampp / і г.д. / дадатковыя /, На першы погляд усё выглядала выдатна. Правілы для лакальнай сеткі былі сярод. Акрамя адкрыцця лакальнага хаста. WTF ??? Я паглядзеў на бервяно-і бачыць, што мой доступ адсякаецца konfiguatsiyata. Вось цяпер, што я ахнуў і адкрыта некалькі менш поспехі знайшоў праблему. След като преглеждах httpd.conf-а видях в Allow/Deny клаузите един последен ред Патрабуюць усё прадастаўлена. Аб эўрыка. Гэта новы механізм кантролю, які ўступіў у Апач 2.4.x. Ён дае доступ або адмову любога такога штрафу, у асноўным імітуюць Дазволiць / Забаранiць функцыянальнасць :). За да поправим проблема добавяме Require all granted в директивите за папката /opt/lampp/phpmyadmin. Пасля таго, як змены ў мяне выглядае як

<каталог “/Opt / lampp / PHPMyAdmin”>
AllowOverride AuthConfig Limit
заказ дазваляюць,адмаўляць
Дазвольце ад усіх
Патрабуюць усё прадастаўлена
</каталог>

 

Viangi можа паспрабаваць іншы дзікі, напрыклад, каб перайменаваць тэчку PHPMYADMIN нешта іншае, а не псеўданім. Але гэта непрыгожа і не вельмі значнай 🙂

p.s Яны спыталі мяне, чаму я выкарыстоўваю XAMPP ня чыстую ўстаноўку ўсіх кампанентаў, як іх мой Debian які нарадзіўся – отговорът е много много простМЪРЗЕЛ. Мързи ме да напиша няколко команди после да си пипна конфовете и прочие. Доста по лесно е сваляш целия пакет разархивираш и палиш 😉

падтрымліваючы Zemanta

Пакінуць адказ

Ваш адрас электроннай пошты не будзе апублікаваны. Абавязковыя палі пазначаныя *

Анты-спам *