XAMPP 1.8.0 reg phpmyadmin na opgradering

'n paar dae gelede het uit XAMPP 1.8.0 gister na die opgradering van weergawe 1.7.7 Ek het'n nogal interessant probleem. Phpmyadmin nie oop nie, en ek gerol met 403

Toegang verbode!


Nuwe XAMPP sekuriteit konsep:

Toegang tot die verlangde voorwerp is slegs beskikbaar vanaf die plaaslike netwerk.

Hierdie instelling kan ingestel word in die lêer “httpd-xampp.Conf”.

Onmiddellik het ek oopgemaak die httpd-xampp.conf wat ek het is in /kies/lampp/etc/ekstra/, met die eerste oogopslag, alles lyk goed. Reëls vir die LAN was OK. Saam met die opening van die plaaslike. WTF ??? Kyk na die log en ek sien dat my toegang is afgesny van konfiguratuta. Nou al wat ek ahaha en, eerlik gesê, 'n bietjie geluk, ek het gevind dat die probleem. След като преглеждах httpd.conf-а видях в Allow/Deny клаузите един последен ред Vereis dat alle toegestaan. Oor Eureka!. Dit is'n nuwe beheer meganisme, wat is ingesluit in apache 2.4.x. Met hom gee nie toegang tot of kwytskelding van sodanige vereiste, basies naboots Aktiveer/deaktiveer funksies :). За да поправим проблема добавяме Require all granted в директивите за папката /opt/lampp/phpmyadmin. Na die verandering van my lyk so

<Gids “/kies/lampp/phpmyadmin”>
AllowOverride AuthConfig Beperk
Om voorsiening te,verbod
Laat van al
Vereis dat alle toegestaan
</Gids>

 

Terwyl dit waar is, kan jy probeer om'n ander wild, byvoorbeeld, om die naam van die phpmyadmin gids tot iets anders, en nie alias. Maar dit is lelik en nie besonder betekenisvol 🙂

p.s het my Gevra hoekom ek gebruik XAMPP in plaas van'n skoon installasie van al die komponente, en dat is, my Debian is gebore – отговорът е много много простМЪРЗЕЛ. Мързи ме да напиша няколко команди после да си пипна конфовете и прочие. Доста по лесно е сваляш целия пакет разархивираш и палиш 😉

Versterk deur Zemanta

Laat'n Antwoord

Jou e-posadres sal nie gepubliseer word nie. Vereiste velde is gemerk *

Die Anti-SPAM *