Packet Tracer

Beeld via Wikipedia

Vandag het ek het om te wys een van die simulasie in Cisco Pakkie Tracer op'n masjien wat nie geïnstalleer nie. In die Algemeen is maloushina, wat Cisco is vir x86 masjiene, en my motor was x64. Wanneer jy probeer om te installeer sterf met lelike boodskap

Probeer om dit te installeer pakket nou
dpkg: fout tydens die verwerking van PacketTracer-5.3_3.i386.deb (–installeer):
pakket argitektuur (i386) nie ooreenstem stelsel (amd64)
Foute teëgekom het, terwyl die verwerking van:
PacketTracer-5.3_3.i386.deb

Oor die algemeen alles is natuurlik Debian-Europese installasie pakket nie wil hê om te installeer, want dit is vir'n ander argitektuur. Hierna, die probleem is duidelik dpkg + gedwing om te installeer sal verbypaaie foute vir verskillende platforms. Bin-pese installeerder lêer, die installeerder real is net onttrek argief dat uitpak in /tmp/selfextract.XXXXX gids waar XXXXX is'n arbitrêre string. Hierdie gids is geleë .deb lêer Pakkie Tracer-'n. Die installasie is gedoen met die opdrag

dpkg -i --force-all /tmp/selfextract.XXXXX/PacketTracer-5.3_3.i386.deb

Natuurlik met wortel voorregte.

Versterk deur Zemanta